
Lesson 1 - Advertisements 1 

LE S SON  1   

ADVERTISEMENTS 
 
OBJECTIVES 

Upon completion of this lesson, you should be able to: 

� Start Microsoft Publisher. 

� Identify the parts of the Microsoft Publisher window. 

� Add text boxes. 

� Enter text into a text boxes. 

� Format text in a text boxes. 

� Move and size text boxes. 

� Add a picture frame and insert a picture into the frame. 

� Format a picture frame. 

� Add a border to surround a frame. 

� Save and print a publication. 

ESTIMATED TIME: 4 HOURS 

What is an Advertisement? 

An advertisement (ad) is a message designed to promote a product, service, event, or 
idea. It should be simple and to the point and it should spark your interest with a catchy phrase 
or logo. 

Design Considerations for Advertisements 

There are many design considerations when creating an advertisement. Following are 
some things that must be taken into account when the ad is being designed: 

� Size—The ad size will depend on the publication in which it will appear. It may be in a 
newsletter, magazine, or newspaper. Although ads are designed somewhat differently for 
the three types of publications, you need to find out the requirements for the ad size because 
it will have to fit into a predetermined layout. Some ads cover a full page, while others 
cover one-half page, one-quarter page, or less. Small ads have to stand out because they 
must compete with all the other information on a page. 

� Headlines—Avoid all capital letters (all caps). All caps are hard to read because of the 
uniform height of the letters. 

� Font Design—Use no more than two typefaces in a publication. (You’ll learn about font 
design or typefaces later in this lesson.) 

� Placement of Objects—Place the most important objects in the upper third of the ad. 
People will not spend a lot of time reading an ad and may never get to the bottom portion. 

� Business Name—Make sure the business name is big and bold. Avoid all caps. 
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�  White Space—Make sure the objects are not too crowded within an ad and that there is 
empty or “white” space surrounding objects. 

� Cost—Make sure you find out the cost of the ad you wish to run so you keep within your 
budget. 

In this lesson you will be creating an advertisement to be placed in a newsletter for the 
Otter Creek Seniors Center. The ad will inform senior citizens of their bus riding privileges. 
The completed publication will look much like Figure 1-1. 

What is Microsoft Publisher? 

Microsoft Publisher is a page layout or desktop publishing 
program. By definition, desktop 
publishing is a system or set of tools used 
to combine text and/or graphics into a full-
page layout. All businesses publish 
documents of various types and sizes. 

You will find this software to be very 
user friendly while providing you with all 
the necessary tools to create publications 
ranging from simple to complex. All 
publications are made up of objects, such 
as text or graphics. In Publisher, all 
objects are inside frames. These frames 
can be moved around on the page and they 
can be resized. 

Starting a New Publication 

When you start Microsoft Publisher, 
the Getting Started with Microsoft Office 
Publisher 2007 appears, divided into three 
panes. Study Figure 1-2 as you read the 
descriptions below. 

• Getting Started. This is at the top 
of the left pane and offers you 
popular publication types. 

• My Template. This choice is also 
at the top of the left pane. It is a place for you to access customized templates that you 
have created and saved for frequently occurring formats.  

• Publication Types. Here Microsoft provides a complete list of types of publications. 
Each choice contains multiple templates provided by Microsoft as well as blank page 
sizes. 

• Popular Publication Types. In the middle pane, you should see icons representing the 
most-used types of publications 

• Recent Publications. At the far right, the start-up window lists your most recent 
publications as well as a From file option to open a stored file not in the “Recent” list. 

FIGURE 1-1 

Completed Lesson 1 Project  
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Exercise 1.1 

1. With the Windows desktop showing in on your screen, click the Start button [Start Button Icon] 

on the Taskbar 

2. Click Programs and choose Microsoft Publisher. 

3. If the New Publication window illustrated in Figure 1-2 appears, study the parts described 

above. Then click Blank Page Sizes (the first choice in the Publication Types section of the 

task pane). 

4. Scroll down slightly and click once to choose Letter (Portrait) 8.5 x 11. Look at the information 

in the Right Pane about the 8.5 x 11” page size you have chosen. 

5. Finally, click Create at the bottom right of the window, and keep the file open for the next 

exercise. 

The Microsoft Publisher Window  

If you have not seen Microsoft Publisher before, you may be surprised to see all of the 
toolbars and rulers. It is a busy window! Following are descriptions of the various items in the 
Publisher window. These items are shown in Figure 1-3. 

FIGURE 1-2 

New Publication Window 
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MENU BAR  

At the top of the window below the title bar is the menu bar. These menu items open drop-
down menus that list all the commands available in Publisher.  

TOOLBARS 

Below the menu bar and way at the left of the window are various toolbars. The toolbars 
that are active will be determined by what object you are working on in your window. Toolbars 
offer shortcuts to tools that are in the menus on the menu bar. 

RULERS 

You should see two rulers. One is a vertical ruler that runs along the left edge of the 
window and the other is the horizontal ruler that shows below the toolbars. These rulers are 
very useful when placing and sizing objects. 

PUBLICATION DESIGNS 

At the left you may see a Task Pane offering formatting choices, publication choices, or 
design choices complete with templates. We will be working with these designs in later lessons. 

DOCUMENT PAGE  

The document is represented by the picture of an 8½- x 11-inch page in the middle of the 
window. Inside the document page are light blue dotted lines for the margins and the columns.  

SCRATCH AREA 

A gray area that is referred to as the Scratch Area surrounds the document page. Objects 
waiting to be placed in the publication can be placed temporarily in the Scratch Area. 

SCROLL BARS 

Along the bottom and the right side of the window are the scroll bars that are used to move 
the document left and right as well as up and down in the window. When you are working in a 

 FIGURE 1-3 

Microsoft Publisher Window 
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close-up of your document, you may need to scroll horizontally to see the beginning of a line or 
vertically to see the top of a page. 

ASK A QUESTION 

In the upper right-hand corner of the window you will see an Ask a Question box on the 
menu bar. You can key questions in this box to quickly find help with the software.  

PAGE NAVIGATION CONTROL 

In the lower left corner of the window is a Page Navigation control showing you how 
many pages are in the publication and what page is currently showing in the window. 

OBJECT POSITION AND SIZE BOXES 

At the bottom of the window and toward the right are the Object Position and Object Size 
Boxes. The Object Position box gives the location of a selected object in relationship to the zero 
marks on the horizontal and vertical rulers. The position is determined using the coordinates of 
the upper left corner of the object. If no object is selected, only the X and Y coordinates of the 
mouse pointer will be shown. In the Object Size box, the first measurement is the width and the 
second is the height. You will become quite familiar with these features as you use the program. 

Exercise 1.2 

1. Click the X in the upper right corner of the Task Pane (Format Publication Pane at the left of the 

window) to close the pane.  

2. Move your mouse so the pointer moves around on the window. Notice the little hairline markers 

that appear on the vertical and horizontal rulers to identify your exact location on the page. Also 

notice how the values in the object position box change. 

2. Carefully position the tip of your pointer in the upper left corner of the document area. Notice 

that the hairline markers on the both rulers will be at zero. 

3. Note that the blue box on the vertical scroll bar is about 

halfway between the top and the bottom. Drag it all the way 

to the bottom of the scroll bar.  

4. Now drag it all the way to 

the top. Your document 

will move down. Finally, 

position it about at the 

center again and try 

moving the horizontal 

scroll bar at the bottom of 

the window. 

5. Finish by centering the 

page in your window. Keep 

the document open. 

FIGURE 1-4 

Uncluttered Publisher Window 
 With Different View of Task Pane 
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Viewing the Task Pane 

In the previous exercise you began by closing the pane at the left. This area is used for a 
variety of functions, depending on what you are doing with your publication. You can redisplay 
a pane similar to the one that showed when you began Publisher by opening the View menu and 
choosing Task Pane. Figure 1-4 shows the Publisher window with the main Task Pane showing. 
This pane appears if you click the Publisher Tasks button on the toolbar just above the task 
pane. You can hide the Task Pane again by clicking the small X in the upper right corner of the 
Task Pane. 

Exercise 1.3 

1. Click the View menu and choose Task Pane.  

2. Click the dark arrow that points down next to the x to see all of the available task panes. 

3. Scroll down to Format Publication to return that task pane and look at the options. 

4. Close the Task Pane again by clicking the X in the upper right corner of the Task Pane. 

Viewing the Page 

Publisher provides different levels of magnification of the page currently being displayed. 
The levels range from full page, where the entire outline of the page shows but the objects are 
small, to 800 percent, where very little of the page shows, and the print is eight times as big as it 
will be when the document is printed. 

The advantage of all of these choices is that it allows you to zoom in on a detail for close 
work or to back out to the full page to see the overall layout of the element. You can change 
magnification in three places: 

• View menu, Zoom submenu 

• Zoom box on the first toolbar (see Figure 1-5) 

• Right clicking any part of the document page and choosing Zoom 

Exercise 1.4 

1. Click the drop-down arrow beside the Zoom box (see Figure 1-5) to see the list. Try several of 

the sizes and watch as your page size changes. 

2. Use the + and – buttons to the right of the Zoom box (see Figure 1-5) to change the view. Then 

return to the Whole Page option. 

3. Right click on any part of the document page and click Zoom to display a submenu of 

magnification choices. Choose 100%. (The Selected Objects 

choice is not available because you did not click on an object.) 

4. You can toggle between views with the F9 key. Change the 

magnification to 50% and press F9 again. It should change to 

100%. Press F9 again. It should change back to 50%. 

FIGURE 1-5 

Zoom Box 

����Tip:  Publisher has dozens 
of keyboard commands like 
F9 in Step 4. Most of these 
commands are listed in Ap-
pendix B. Check this list fre-
quently to see how you can 
work more efficiently. 
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5. Open the File menu and choose Close. You will be asked if you want to save the changes you 

made to this publication. Click No. This will return you to the main Publisher start-up window. 

Page Setup 

Despite the fact that Publisher offers you a wide variety of sizes, there will be times when 
you need to make adjustments to your page. This includes determining the size of the 
publication and setting the margins to contain the objects in your publication. 

PAGE SIZE 

Publisher 2007 enables you to create a publication of any size. For an advertisement for a 
newspaper or newsletter or magazine, that is important. In Publisher 2007, you will make a 
custom size choice from the main start-up menu and enter the desired width and height of the 
publication. 

LAYOUT GUIDES 

The margins that show on the page are called “layout guides.” These guides do not print, 
but they plan an important role in the design of the document. They provide a visual “reference 
for the margins of the document and help you with the placement of the elements in the 
publication—text as well as graphics. 

There are several types of layout guides. Most are used for margins, although when you 
are working in some of the later lessons where the text and objects are arranged in columns, you 
will learn to set “column guides” for your documents. 

In the next exercise, you will be working with a dialog box (see Figure 1-6). This is a 
Windows feature where you enter instructions to the program about formatting choices. 
Whenever you are working in a dialog box and press Enter, the dialog box is closed. If you 
have several changes to make in a dialog box, move from text box to text box (the places where 
you key the information) with the Tab key or use the mouse to click the insertion point into the 
desired text box for the change. Press Shift+Tab to move to the previous box. If you 
accidentally press Enter, you can reopen the dialog box to make the remaining changes. 

Exercise 1.5 

1. With the main Publisher 

2007 start-up window 

showing. Click Blank Page 

Sizes in the Publication 

Types. Scroll down a little to 

the bottom of the first group 

of page sizes and choose 

Custom page size . . . . 

2. Look at the dialog box that 

appears. At the left you will 

make your choices. At the 

right, you will see the results 

of those choices. Click in the 

Width box and key 4. 

FIGURE 1-6 

Page Setup Dialog Box 
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3. Tab to the Height box and key 5.  

4. Tab to the text box for the top Margin Guide and key 0.25. Tab again and enter the same value 

for each of the margin guides. Click OK to close the Custom Page Size dialog box.  

5. Click Create in the lower right center to create the document. Look at the rulers above and to 

the left of your publication. Note that your “page” now measures 4 x 5 inches and that you have 

quarter-inch margins. 

Layout Guide Options 

Layout Guides can also be set from Arrange menu. This menu offers a variety of tools to 
make your work in Publisher more efficient and more concise. 

SNAP TO GUIDES 

You can use the layout guides to line up objects exactly. 
This is done by turning on an option called To Guides 
from the Snap choice in the Arrange menu. 

While Snap to Guides feature is useful for views of 
all sizes, it is especially valuable when you are working 
in Full Page view because the layout guides become 
“sticky.” The mouse pointer catches slightly when it 
passes over a sticky guide. The pointer will also tend to 
jump to the next guide as it is being moved across the 
window. 

When the To Guides option has been chosen, a 
check mark (�) will appear at the left of the option, as 
illustrated in Figure 1-7. To turn the option off, you must 
again choose it from the Arrange menu. 

HIDE LAYOUT GUIDES 

You can hide the layout guides to make more display area available on the document page. 
The option to show or hide Boundaries and Guides is found in the View menu. 

Exercise 1.6 

1. Open the Arrange menu and point to Snap. The menu should look like Figure 1-7. 

2. Click on To Guides. This will turn off the guides. 

3. Open the Arrange menu again and point to Snap. Notice the check mark (K) is not there. Click 

To Guides to turn it back on. 

4. Open the View menu and choose Boundaries and Guides. The menu will disappear, and you 

will see your document page without the margin guides. 

5. Return to the View menu. Notice that now the check mark is missing at the left of Boundaries 

and Guides. Click Boundaries and Guides to display your layout guides. 

FIGURE 1-7 

Arrange Menu/Snap Submenu 
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6. Keep the file open for the next exercise. 

Creating an Object 

To create an object on the document page, you must first create a frame for the object. A 
frame is a container for an object. You must choose a tool from the Objects Toolbar (Figure 1-
9) to create a frame. We’ll begin at the top of the toolbar and discuss each button. 

OBJECTS TOOLBAR 

The Objects toolbar illustrated in Figure 1-8 is the row of buttons at the left of the window. 
Each tool performs a specific action. Notice that the tools appear to be grouped. At the bottom 
of the Objects toolbar is an arrow that leads you to a dialog box where you can add or remove 
buttons on the toolbar—in other words, you can customize the toolbar to meet your needs. 

� Select Objects—The first tool on the top is known as the Selection tool. 
That button should be enclosed in a blue box because the pointer is 
chosen by default. When you choose one of the other buttons, the tool 
you choose will be enclosed in a box. 

� Text Box—The second tool bears the text box icon. This tool is used to create a frame 
into which you’ll place text. 

� Insert Table—The Insert Table tool is used to create frame containing a table that 
consists of rows and columns into which text can be entered. You can plan a table and 
perform your own formatting or you can choose from 20 preformatted tables. 

� Insert WordArt—The Insert WordArt tool is used to draw a frame into which you can 
place fancy text of some kind such as a title. 

� Picture Frame—The Picture Frame tool is used to draw picture frames into which you 
can import clip art or a picture from your files or from a scanner or camera. 

� Line—The Line tool is used for adding rules (lines) to your document. Those lines can 
be any length or any width and can be vertical, horizontal, or at an angle. 

� Arrow—The Arrow tool is used for adding arrows that typically point to another 
object in the publication. 

� Oval—The Oval tool is used to draw ovals or circles. 

� Rectangle—The Rectangle tool is used to draw rectangles or squares. 

� AutoShapes—The AutoShapes tool is used to create a variety of other geometric 
shapes. 

� Bookmark—This tool is used to insert a bookmark into your document at the desired 
location. Bookmarks are used to bring you quickly back to a desired point in the document. 

� Design Gallery Object—This tool is used to enter Publisher-designed objects such as 
banners, or coupons, and also to pull quotes into your publications. 

� Content Library—You can save objects to be used from one publication to another. This is 
a helpful tool when it is desirable to have uniform objects for the publications in your 
organization. 

FIGURE 1-8 

Objects Toolbar 
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Using the Text Box Tool 

If you use word processing software, you generally just start keying on the page where you 
want the text to appear. This procedure is possible in some desktop publishing programs as 
well. In Microsoft Publisher, however, you must first create a frame into which the text will 
either be keyed or imported from a text file. 

It is simple to create a text box. Begin by clicking the Text Box tool. Your pointer 
becomes a crosshair instead of an arrow. Position the mouse pointer in the document page at 
one of the corners where you want your text box to begin (usually the upper left corner). 
Depress the left mouse button and drag the crosshair pointer (usually toward the lower right 
corner) until your box is approximately the size you’d like it to be. At that point, release the 
mouse button. When your box has been created, it will have white circles on all sides and 
corners. These circles are called handles and are 
used for resizing the box. If you don’t like the size 
of the box or the current position of the box, you 
will be able to resize it and move it. You will learn 
that later. 

There is also a green circle that is attached to 
the top of the box by a line. This is a tool that may 
be used to rotate a box. 

Exercise 1.7 

1. Click the Text Box tool on the Objects Toolbar. 

Look at the pointer. Its new shape is called a 

crosshair. 

2. Point with the mouse pointer at the upper left 

corner of the layout guide and depress the left 

mouse button. Drag to create a box that 

measures about 3.5” wide and 3.0” high. 

(Watch the Object Size Box in the lower right 

corner for the measurements as you draw the 

box.) Release the mouse button when you are 

done. The box should look somewhat like the 

one in Figure 1-9. 

3. Look at the sizing handles surrounding the box. Find the green rotate tool.  Keep the publication 

open as you read on. 

SIZING AND MOVING A TEXT BOX 

Drag one of the handles of an object to make the object smaller or larger. To use this 
method of sizing an object, make the object active by pointing to it with the mouse pointer and 
clicking once. Then move your pointer over one of the handles until you see a double-headed 
arrow. When the arrow appears, hold down your left mouse pointer and drag. Watch the Object 
Size Box in the lower left corner of the window as you adjust the size. The first value is width 
and the second value is height. 

You can use the Measurements toolbar to take the guessing out of sizing. Simply key in 
the width and height or use the spinner buttons to the right of the width and height text boxes to 

FIGURE 1-9 

New Text Box Object 
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increase or decrease the size. The Measurement toolbar can be chosen from the Toolbars choice 
in the View menu or you can double click on the Object Position box or Object Size box. You 
can move it around in the window by pointing to the bar at the top and 
dragging it to the desired position. The Measurement toolbar looks like 
Figure 1-10. The Measurements toolbar can also be used to format text 
in a text box. This will be covered in Lesson 2. 

Moving an object can also be done in two different ways. You can drag 
the object around the page using the Move icon (looks like 4-headed arrow) 
and release the mouse button when the object is in the desired position. You 
can use the Object Position Box in the lower right corner of the window if you 
have a specific position in mind. The x value is horizontal and the y value is 
vertical. These positions are measured from the upper left corner of the 
document where the horizontal and vertical rulers begin at zero. The 
Measurement toolbar can also be used to specify a position by keying a value 
in the x and y boxes. 

Exercise 1.8 

1. Click the Text Box you created in the previous exercise, if 

necessary, to select it. 

2. Point to the handle in the lower right corner. When you see the 

diagonal double-headed arrow, hold down your left mouse 

button and drag toward the lower right corner of the document 

page. 

3. Release the mouse button when you see the Object Size Box show approximately 3.5” x 4.5”. 

This takes lots of practice, so don’t be concerned if it is not exact. 

4. From the View menu, choose Toolbars and then Measurement to display the toolbar. 

5. Key 3.5 in the width box and 3 in the height box as shown in Figure 1-10. Press the Tab key 

once to accept the changes. Keep your document displayed as you read on. 

Keying Text 

Adding text to a text box is easy. When the text box is active (it has handles around it), 
you should see an insertion point blinking in the box. This is where the letters will appear as 
you key them. You will probably want to increase the magnification of the screen so you can 
read the letters you are keying.  

When you reach the right side of the box as you are keying text, you should let the text 
wrap around to the next line unless you want to start a new paragraph. Press Enter once or twice 
to start a new paragraph. 

In the first exercise, you are going to key only part of the text. The company name and 
address will be in a separate text box. 

FIGURE 1-10 

Measurement Toolbar 

����Tip:  When keying sizes 
into the appropriate boxes on 
the Measurement Tool Bar, 
you do not have to key the 
inches sign or quotation 
marks. 
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Exercise 1.9 

1. Activate the text box by clicking in it. 

2. Increase the magnification by pressing F9 or using 

Zoom so you can see the text you are keying. 

3. Key the text in Figure 1-11. (If you make any 

keying errors, you will learn how to correct them 

soon.) Keep the publication open as you read on. 

Editing and Formatting Text 

Here are some techniques for editing text: 

� If you catch yourself making an error as you are keying text, use your Backspace key to 
delete the characters to the left of the cursor. 

� Use your Delete key to delete characters to the right of the cursor. 

� If you see a word underlined in red, point to the word with the mouse pointer and right-click 
to see what spelling suggestions are available for the underlined word. If you see the correct 
spelling in the list, click to insert it. 

� If you see a word(s) underlined in green, right click and read the suggested grammar 
correction. If you like the suggestion, click to insert it. 

� To insert a word, click to position the insertion point where you want to add the word. Then 
key the new word. 

� To delete a word, double-click it to select it and press Delete. 

Exercise 1.10 

1. Check for any words underlined in red. Right click the word and select the correctly spelled 

words. 

2. Check for any words underlined in green. Right click the word and select the grammatically 

correct words. 

3. Delete the word Bus in the third line. 

4. Add the word taxi in the second to last line after the word subsidized. Keep the publication 

open as you read on. 

When you create a text box, the Formatting toolbar becomes active. You may choose some 
formats before you begin keying. If the text is already keyed, you must select the text that is to 
be formatted and select the desired formatting (see Figure 1-12).  

Four types of text formatting will be used in this lesson. They are font design, font size, 
font style (bold, italics, and underline), and paragraph alignment. 

�  Font Design—The design of the type refers to the typeface. Examples of typeface are 
Times New Roman and Arial. If a font has feet on the letters, it is referred to as a serif font 
and looks like what you are currently reading. Times New Roman is an example of a serif 

FIGURE 1-11 

Text to Key 
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font. Serif fonts are good for body text such as paragraphs. If a font has no feet, it is referred 
to as a sans serif font and looks like the steps in the exercises. Arial is an example of a sans 
serif font. Sans serif fonts are best used for display text such as titles and headings. Font 
design can make a difference on the tone of the publication. One font design may be best for 
a conservative publication and another may be best for a more creative publication. Choose 
a font that helps convey the message.  

� Font Size—Fonts are measured in points. One point equals approximately 1/72 of a vertical 
inch. So 72-point text would be one inch tall. Type is measured in points ranging from 6 
points (6 pt.) on the small end to several hundred points on the large end. Font size for 
paragraphs is generally 10 or 12 points. Titles typically have a larger font size than the 
paragraph font size so that they stand out. 

� Font Style—Font Style is a variation within a font design such as bold, italics, and 
underline. Italics and bold work well for making words stand out. Underline is rarely used. 

� Paragraph Alignment—Alignment refers to the left and right sides of a paragraph. 
Typically, paragraphs are formatted with left alignment and titles are formatted with center 
alignment. 

o Left—ragged right, even left 

o Center—ragged left and right  

o Right—ragged left, even right 

o Justify—even left and right 

Exercise 1.11 

1. Select the text box you edited in the previous 

exercise. Use the tools on the Formatting toolbar to 

format the text as directed in the next steps. 

2. Select the first three lines and format them as 

follows: Impact, 26 pt. bold, and center alignment. 

3. Select the next two lines and format them as 

follows: Arial, 16 pt. bold, and center alignment. 

4. With the same two lines selected, click the Bullets 

button. (Your bullets may not be the same size as 

those in Figure 1-13.) 

FIGURE 1-13 

Formatted Text 

 

FIGURE 1-12 

Formatting Toolbar 
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5. Select the paragraph with the slogan and format it as follows: Arial, 20 pt. italics, and center 

alignment. 

6. Grab the sizing handle at the bottom of the text box and drag it up a little below the text in the 

box. (If you go so far that you lose some text, readjust it.) 

7. Keep the publication open as you read on. 

Saving a File 

When working with Publisher, 
you should save your work often so that 
nothing is lost if your computer power is 
interrupted. You have enough completed 
now to warrant saving. Check with your 
instructor as to where you should save 
your files. For these materials, it will be 
assumed that you are saving your work 
non-secure removable USB drive.  

Although you will be told in these 
materials what to name each of your 
publications, filenames may be up to 
255 characters, including spaces. 
Publisher files often are large in size depending on the objects. Graphics, WordArt, and large-
sized fonts add to the size of a publication. 

 

Exercise 1.12 

1. Display the File menu and choose Save As. 

2. Ask your instructor for the location where this file should be stored. Name the file bus ad xxx, 

substituting your initials for xxx. Publisher will automatically append the extension .pub  to your 

file name. (See Figure 1-14.) 

3. Click Save. Keep the publication open as you read on. 

Creating Another Text Box 

In the next exercise you will create another text box, enter text, and format the text  like 
you used did for the first exercises.  

Exercise 1.13 

1. With bus ad xxx showing in the window, choose the Text Box tool on the Objects toolbar. 

2. Draw a text box below the first text box that begins at 3.25” on the vertical ruler. Make it 3.5” 

wide and 1.25” high.  

3. Key the text shown in Figure 1-15. 

FIGURE 1-14 

Save As Dialog Box 
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4. Select and format the first line in Arial, 14 pt. 

bold, and center alignment. 

5. Select and format the second line using Arial, 

18 pt. bold, and center alignment. 

6. Select and format the address and city using 

Arial, 10 pt., and center alignment. 

7. Select and format the last line using Arial, 18 

pt., bold, and center alignment. Keep the 

publication open. 

Filling a Frame With Color 

A common formatting technique is adding 
background color to a frame to make it stand out. 
This is known as a screen. The color you choose 
depends on what is in the frame. If the frame 
contains text, the color should not be so dark that it 
makes the text hard to read. Often the text should 
be bold to make it stand out within the formatted 
text box.  

Use the Fill Color button to add color to a 
frame. This button displays a palette of colors 
(see Figure 1-16). Publisher bases the available 
colors on the color scheme, which is determined 
when a publication is created. A color scheme 
contains five colors that complement each other. 
These colors are assigned to various text objects. 
The default color scheme is Bluebird. Color 
schemes will be covered in a later lesson. 

 

Exercise 1.14 

1. With bus ad xxx showing in the window, 

select the new text box. 

2. Click the arrow beside the Fill Color button 

on the Formatting toolbar. 

3. Choose a gray or similar color that is not too 

dark. 

4. Click the Save button on the Toolbar (the 

one that looks like a disk) to do an interim 

save of your publication. 

 

FIGURE 1-15 

A Second Text Box Frame 

FIGURE 1-16 

Filling a Frame with Color 
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Adding a Picture 

Depending on the size of the ad, a picture may be added that will help attract attention to 
the ad or help clarify the message.  

A picture can be added from a picture file stored on your computer system or a removable 
disk such as a floppy disk or a CD-ROM or it can be added from the Microsoft Clip Organizer. 
In this lesson, we will add it as a picture file. It is necessary to use only those graphic formats 
that are compatible with Microsoft Publisher. Those formats include the following: 

� Graphics Interchange Format (.gif, gfa)  

� JPEG File Interchange Format (.jpeg, .jpg, .jfif, .jpe)  

� Microsoft Windows Bitmap (.bmp, .rle, .dib, .bmz)  

� Microsoft PhotoDraw or PictureIt! (.mix)  

� Portable Network Graphics (.png)  

� TIFF, Tagged Image File Format (.tiff)  

� Windows Enhanced Metafile (.emf)  

� Windows Metafile (.wmf)  

Other graphic formats may be added but special graphic filters need to be installed in order 
for those types of files to be added. These graphic files include the following: 

� Encapsulated PostScript (.eps)  
� Computer Graphics Metafile (.cgm) 

� CorelDRAW! (.cdr) 

� Macintosh Picture (.pict, .pct) 

� WordPerfect Graphics (.wpg) 

� Compressed Macintosh PICT (.pcz) 

A picture frame can be placed by itself on a document page or it can be layered with other 
frames. In this lesson, you will be layering the picture frame on top of the text box because we 
need to keep the ad to a certain size. When objects are layered, it may be necessary to tell 
Publisher what object should be at the top and what object should be at the bottom. Since the 
text box was created first, it should not be a problem to add the picture frame on top of the text 
box. 

To insert a picture, click the Picture Frame button on the Object toolbar and then draw the 
frame in your publication. When you do this, the Insert Picture dialog box will appear as shown 
in Figure 1-17.  

Data Files 

A number of prerecorded files (both text and images) are provided for you to use as you 
prepare your publications in this course. One of those files is needed for the next exercise. You 
will need to check with your instructor to find out where the prerecorded data files are located.  
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Exercise 1.15 

1. With bus ad xxx open in the 

window, click Picture Frame on 

the Objects toolbar. Choose 

Picture from File. 

2. With your mouse, point to the 

upper left corner where the top 

and left margin guides meet. 

Press and hold the mouse button 

as you drag down and to the 

right until the Size Box measures 

approximately 1.5” wide and 

1.5” tall. 

3. When the Insert Picture dialog 

box opens, locate the folder that 

contains the prerecorded data files and locate Bus.jpg 

4. If you do not see a preview of the picture file, choose 

Views on the Insert Picture dialog box toolbar and change 

to Preview. 

5. Double click the bus to insert the Bus picture, or click 

once to select the file and then click Insert. Click the Save 

button on the Standard toolbar. 

Sizing and Moving a Picture Frame 

With the picture frame in the ad, select it so 
that the handles appear. You need to make it 
bigger. You could use the same method you used 
for the text box, which would be to move your 
mouse pointer over a handle until a Resize icon 
appeared and then hold down the left mouse 
button and drag in or out. This works fine when 
you are not too concerned with an exact size. In 
this case, you need to make it an exact size so 
you are going to use the Format Picture dialog 
box (Figure 1-18) to specify a size. 

The Format Picture dialog box can be 
opened by right clicking on the picture frame and 
choosing Format Picture or by choosing Picture 
from the Format menu. In the latter case, make 
sure the picture frame is selected first. With the 
Format Picture dialog box open, choose the Size 
tab and key in the desired height and width.  

Once a picture is inserted in a publication, 
the Picture toolbar tools become available. 

FIGURE 1-17 

Insert Picture Dialog Box 

����Tip:  If you do not want the pic-
ture to be sized proportionately, 
make sure the Lock aspect ratio 
option is off. The problem with turn-
ing this option off is that you risk 
resizing the picture disproportion-
ately and it could change the look 
entirely. 

FIGURE 1-18 

Format Picture Dialog Box 
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Overflow 

If a text box is not large enough to hold all the text as a result of resizing, a box with an A 
will appear in the lower right corner of the box. This is referred to as the Text in Overflow 
indicator. When there is too much text for the box, it is stored in a special memory called the 
overflow area. It stays there even if the file is closed. When the box is made large enough to 
show all the text, the Text in Overflow indicator will disappear. (Sometimes a text file has extra 
blank lines at the end. These blank lines are considered text and make the text file seem larger 
than it really is.) 

Exercise 1.16 

1. Your bus ad xxx document should still be open in the window. 

Right click on the bus picture. 

2. Choose Format Picture. 

3. Choose the Size tab. 

4. Make sure the Lock aspect ratio is not 

selected (no check mark). 

5. Key 1.5 in the Height text box. The size should 

automatically appear in the Width text box. 

Click OK. 

6. Notice in Figure 1-19 that the slogan has 

disappeared. An A…  in a box appears at the 

bottom of the top text box. This means that the 

there is more text than what is showing and 

that the excess is in the overflow area. 

7. Click on the bottom middle handle of the top 

text box and drag the handle down until the 

missing text reappears. You may need to move 

the lower text box down a little. Keep the 

publication open as you read on. 

Adding a Border 

To add emphasis to an ad, a border can be added to any kind of box. This border can be of 
various thicknesses and colors. To add a border, select the box and choose a border style using 
the Line/Border Style button on the Formatting toolbar. The line styles (Figure 1-20) are listed 
by point measurement. There are 72 points in an inch. The default color is black. In this lesson 
we will not change the color of the border. 

Exercise 1.17 

1. Select the text box at the bottom of the ad. Click the Line-Border Style button. 

2. Select the ¾ pt style. 

FIGURE 1-19 

Ad With Inserted Picture 
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3. Check your work to make sure everything shows and 

looks good. Then click the Save button on the Toolbar 

to save your work again as bus ad xxx. 

The Completed Publication 

Congratulations! You have finished your first 
publication.  

Your publication should look like Figure 1-1. 
The Boundaries and Guides were turned off in the 
View menu for a more finished appearance in the 
figure. 
 

Printing a File 

Up until now you have been working with a soft 
copy, which means you have been viewing it only on 
the screen. To see a hard copy, you need to print it. To print, click the Print button on the 
Standard toolbar or open the Print dialog box from the File menu.  

The Print dialog box (Figure 1-21) offers a choice of printers when you click the drop-
down list to the right of Name. Also, if you have a multiple page document, the print range can 
be selected. You may want to print certain pages or just the current page. Depending on your 
printer, publications that contain graphics, color, WordArt, and large-sized font objects may 
print slowly. In that case, printing one page at a time can help speed things along. While you are 
checking the printed page, you can print another page. You can also select the number of copies 
in this dialog box. The default is one copy. 

Because you are working with a 
publication that is smaller than 8½ x 11, 
you may be able to print more than one 
copy on a page. In the Printing options 
section of the dialog box, you may 
choose how many copies per sheet you 
wish to print. In this exercise, you will 
designate one copy per sheet. 

Exercise 1.18 

1. Open the File menu and choose 

Print. Select your printer, if 

necessary. Leave the Print range at 

All pages and the Number of copies 

at 1.  

2. Select One page per sheet. Click 

Print. 

FIGURE 1-20 

Adding a Border 

FIGURE 1-21 

Print Dialog Box 
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3. Open the File menu and choose Close. Click Yes if you are prompted to save the changes 

made to this publication. Your bus ad xxx document should be closed and you will see a blank 

document page. 

4. Open the File menu and choose Exit to close Microsoft Publisher. 

Summary 
In this lesson, you learned the following: 

� The purpose of a desktop publishing program is to create publications containing text and 
graphics and that require more layout decisions than publications created with a word 
processing program. 

� Microsoft Publisher has an Object toolbar that is used to create boxs for various objects. 

� A text box is an object into which text is either keyed or imported. 

� Text in a text box can be edited and formatted. 

� Graphic files stored in a computer can be inserted using the Picture Frame tool. 

� Picture frames can be moved, resized, flipped, and rotated. 

� Microsoft Publisher is compatible with many graphic file formats. 

� Page size and orientation can be changed in the Page Layout dialog box. 

� Borders can be added to make a frame stand out. 

� Publications can be saved and printed. 

L E S S ON  1  R E V I EW  QU E S T I O N S  

WRITTEN QUESTIONS 

Write a brief answer to the following questions. Use complete sentences. 

1. Explain the purpose of frames in Publisher. 

2. Explain the purpose of the Scratch Area. 

3. Explain the purpose of the position and size indicators in the lower right corner of the 
screen. 

4. Explain the purpose of the layout guides. 

5. Explain the purpose of the Measurements toolbar. 

6. Explain how to add a border to a frame. 

TRUE/FALSE 

Circle T if the statement is true or F if the statement is false. 

T F 1. Picture frames can be moved and resized. 

T F 2. Only Microsoft Publisher graphics can be used in publications. 

T F 3. The Arrange menu is used to change the page size. 
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T F 4. No text editing can take place in a Publisher text box. 

T F 5. Use the Formatting toolbar to create new picture frames and text boxes. 

T F 6. Advertisements are messages designed to promote a product, service, event, or idea. 

T F 7. The pane that appears at the left of the window when you begin a publication is known as 

the Scratch Area pane. 

T F 8. The more fonts you use in an advertisement, the more appealing the advertisement will be. 

MULTIPLE CHOICE 

Circle the best answer to each of the following statements. 

1. What is the box at the top of the window that allows you to look at the document using a 
larger or smaller view? 
A.  Zoom 

B.  Snap to 

C.  Page Setup 

D.  Print 

2. When using the mouse to draw a text box in the Document Page, what icon does the mouse 
pointer become? 
A.  Arrow 

B.  Moving 

C.  Resize 

D.  Crosshair 

3. When moving a text box around in the Document Page, what icon does the mouse pointer 
become? 
A.  Arrow 

B.  4-Headed Arrow 

C.  Resize 

D.  Crosshair 

4. When resizing a text box, what icon does the mouse pointer become? 
A.  Arrow 

B.  Moving 

C.  Resize 

D.  Crosshair 

5. Which dialog box allows you to change the margins of a publication? 
A.  Layout Guides 

B.  Page Layout 

C.  Print 

D.  Save As 

6. Which of the following file formats is NOT compatible with Microsoft Publisher? 
A.  PDF 

B.  TIF 

C.  GIF 

D.  BMP 
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L E S S ON  1  P R O J E C T S  

At the end of each lesson, you will be asked to complete one or more projects to reinforce 
what you learned in the lesson. Fewer explanations are given in the projects—you are, after all, 
applying skills you acquired in the lesson. As you go on to future lessons, the skills you gained 
in this lesson will be tested again and again. Try to remember as much as you can, but know 
that you can look back into the lessons for help when you need it. 

PROJECT 1-1 

The publication will have four different text boxes. Each one will be as wide as the left and 
right margins but of different height. Change the view, if necessary, so you can see what you 
will be keying. 

Use a font that fits the occasion. The font used in Figure 1-22 is Comic Sans MS. The sizes 
may vary depending on the font chosen. 

1. Open the File menu and choose New. Create a blank custom page that is 4.75” wide and 
7.5” tall. Set 0.25” margin guides on all sides.  

2. The first text box starts at the top margin guide. Make it 1.75” tall.  

3. Right align the following paragraphs and format the text as shown in parenthesis. 

Otter Creek (20 pt. bold) 

Children’s Fisheree (20 pt. bold) 

Otter Creek Park—Miller Bay (12 pt.) 

Saturday, August 11, 2007 (14 pt. bold) 

10:00 a.m.-12:00 p.m. (12 pt.) 

4. Create the second text box to start at 2.25” on 
the ruler. Make it 1.75” tall. 

5. Center align the following paragraphs and 
format them as shown in parenthesis. 

Kids 3 to 15 Years Only (14 pt. bold) 

Free pop & lunch for kids & lots of prizes (12 
pt.) 

Check in at the tent the day of the Fisheree 
(12 pt.) 

9:00 a.m. to 10:00 a.m. (12 pt.) 

Only registered kids can enter the contest. 
(14 pt.) 

6. Create the third text box to start at 4.250” on the 
ruler. Make it 0.938” tall. 

7. Center align the following paragraphs and 
format them as shown in parenthesis. 

NO BOATS! (28 pt.) 

Worm Fishing Only! (16 pt.) 

FIGURE 1-22 

Completed Project 1-1 
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8. Create the last text box to begin at 5.25” on the ruler. It should measure 2” tall and end 
at the bottom margin guide. 

9. Key the paragraphs and format them as shown in parentheses. The lines are created 
using the Shift and Underline keys and they may vary in length from those showing in 
Figure 1-23. 

Registration Form (center align, 10 pt. bold) 

Name _________________________________ Age_____ (left align, 10 pt.) 

City ___________________ State _____ Zip __________ (left align, 10 pt.) 

Phone No. ______________________________________ (left align, 10 pt.) 

Mail to: Otter Creek Fishing Club (center align, 10 pt.) 

P. O. Box 372, Otter Creek, WI 54999 (center align, 10 pt.) 

Call (920) 555-0009 if you have questions. (center align, 10 pt.) 

10. Turn on a ¾ pt. border for the bottom text box. 

11. Insert a 1.4” wide and 2” tall picture in the upper left corner. Put it on top of the text 
box. Insert the fish fishing.gif graphic from the data files. 

12. Insert the fish and worm.jpg graphic from the data files in the right side of the third 
text box. Challenge: Change the text wrap for the graphic to None so that it does not 
push the text over. 

13. When you finish, save the publication as fisheree ad xxx, substituting your initials for 
xxx. Print it and close it. 

PROJECT 1-2 

Your mother is a member of the 
Otter Creek Garden Club and she has 
asked you to create an ad for their 
upcoming annual plant sale.  

1. Create a new custom page that is 
4.75” wide and 4” tall. Set 0.25” 
margin guides on all sides.  

2. Create a text box that snaps to all 
four margin guides.  

3. Change the view, if necessary, so 
you can see what you will be 
keying. 

4. Key and format the text in Figure 
1-23. You choose the fonts! The 
two fonts used in the figure are 
Script MT Bold and Arial. You 
must keep the finished ad the 
original size, so choose your font 
sizes carefully. 

FIGURE 1-23 

Completed Project 1-2 
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5. Go to the data files and insert the picture file potdplnt.wmf on top of the text box and 
size it to fit to the left of the text as shown in Figure 1-24. It should push the text to the 
right.  

6. When you finish, save the publication as plant sale ad xxx substituting your initials for 
xxx. Print one copy per sheet and close the file. 

PROJECT 1-3 

Choose a real or imagined upcoming event at your school that needs publicity. Create an 
advertisement for the school newspaper. Save it as school ad xxx substituting your initials for 
xxx. Print it and close it. 


